Seit gestern ist nun Windows 7 RC auf meinem Notebook, einem Samsung R560 Madril mit einem P8400, 4GB Ram und 500GB WD Platte, installiert. Also höchste Zeit für einen vorschnellen Erfahrungsbericht!

Nachdem die x64-Beta nicht wirklich brauchbar auf dem Gerät lief, habe ich die Installation der RC noch einmal in 64bit versucht. Das Ergebnis entspricht den Beta-Erfahrungen, die Hardware an sich funktioniert, die Samsung Dienstprogramme gibt es weiterhin nur für 32bit. So wird die Helligkeitsteuerung des Displays unmöglich, und wenn man sich die Augen nicht verderben will ist ein Arbeiten unzumutbar ob der zu hohen Helligkeit. Also wieder rauf mit der x86-Version:

Im Gegensatz zu der Beta habe ich mich nach einem CompletePC-Backup zu einem Upgrade meines Produktivsystems auf 7 RC entschieden. Die Installation war langweilig: Keine Probleme, keine Fehler. Nach einer gefühlten Stunde und ein paar Neustarts war Windows dann wieder ein nutzbar. Der erste Eindruck war bestens, alles war wie erwartet.

Ich hatte letzte Woche die RC bereits auf meinen Desktop sauber neu installiert und dadurch schon ein paar Erfahrungen sammeln können. Kurz: Alle Anwendungen laufen, das Betriebssystem fühlt sich sehr gut an, ist angenehm schnell und stabil.

Beim Upgrade war das nicht anders. Einzig zwei Kopierschutzanwendungen versagten den Dienst (unter anderem Starforce), woran ich aber auch nichts ändern werde. Die Daemon Tools sind in meiner alten Version nicht kompatibel, da muss ich updaten, wenn ich sie wieder brauchen sollte.

Problematisch wurde es erst bei der Einwahl in das Firmen-WLAN, was ich bereits in einem anderen Eintrag abgehandelt habe.

Erfreulich: Die Samsung-Programme zur Regelung des WLAN, der Energiemodi und der Bildschirmhelligkeit laufen anstandslos, wie schon von Vista gewohnt. Fehlende Treiber (Grafikkarte) wurden sofort über das Windows Update nachinstalliert, inkompatible Hardware gibt es keine. Alles funktioniert!

Auffallend gut an der 7 RC: Die neue Remotedesktopverbindung. Diese unterstützt nun auch die Desktopeffekte von Win 7 zu Win 7. Alle Animationen und Transparenzien sind also auch aus der Ferne verfügbar. Tolles Eyecandy! Sogar Videostreams lassen sich damit Remote flüssig darstellen – entsprechende Anbindung vorausgesetzt.

Eine Änderung scheint es in der Leistungsbewertung der Hardware von 7 gegeben zu haben. So ist der CPU-Score meines Notebooks um 0,5 Punkte, der der Festplatte um 0,3 Punkte höher als bei Vista. Der Arbeitsspeicher verlor 0,1 Punkt, die Grafikkarte im 3D-Modus 0,3. Zumindest bei der Grafikkarte will ich dies aber auf die frühen Treiber zurückführen. Unter x64 zeigte sich die gleiche „Problematik“. Wenn dies kein Fehler ist und Vista nicht noch nachgepatcht wird, ist es in Zukunft schwer Werte von Vista mit denen von 7 zu vergleichen.

Was sonst noch stören könnte: Hin und wieder finden sich ein paar englische Dialoge in dem ansonsten gut eingedeutschtem Betriebssystem. Da sollte man einem Release Candidate aber nicht zu nachtragend sein. Wenn das das einzige Problem bleiben sollte: Bitte!

Eine ausführliche Auflistung der Neuerungen für Endanwender finden sich auf:
http://blogs.technet.com/sieben/archive/2009/05/04/was-ist-neu-im-windows-7-rc-aus-endanwendersicht.aspx

Die Änderungen von Beta zu RC werden auf dem gleichen Blog beschrieben:
http://blogs.msdn.com/e7/archive/2009/02/26/some-changes-since-beta.aspx
http://blogs.msdn.com/e7/archive/2009/03/13/a-few-more-changes-from-beta-to-rc.aspx

Werbeanzeigen

image Wer erwartet hat, dass in der zweiten Folge der neuen TV-Werbekampagne endlich etwas verkauft wird, wird enttäuscht. Diesmal ziehen Gates und Seinfeld bei einer amerikanischen Durschnittsfamilie ein und beziehen dort das Zimmer der Tochter. Der Spot ist wieder unter windows.com zu sehen und diesmal sogar lustiger anzuschauen. Eines der Highlights: Gates liest dem Sohn der Familie eine „Gutenacht-Geschichte“ vor, der Sohn fragt „Are there any monsters in the story?“ und Bill antwortet: „Yeah, but it’s ok, there’s a firewall!“.

Hier der Spot in voller Länge auf Youtube – man achte auch auf den Rucksack mit der „W H G III“-Insignien (William Henry Gates der Dritte):

image Mittlerweile hat Apple mit Version 3.1 die erste finale Version von Safari für Windows veröffentlicht. In einem ersten kurzen Antesten funktioniert (fast) alles tadellos. Nur eins stört: Es gibt noch keine Plug-Ins für die Windows-Variante, die Werbung blockieren können (eben ein Ad Blocker).

Eine Alternative dazu ist eine CSS-Datei, mit der typische Werbefenster ausgeblendet werden. Steven Jay Cohen hat eine eigene Version erstellt, sein Stylesheet veröffentlicht er unter code.google.com/p/adsubtract. Versprochen werden monatliche Updates (allerdings ist die neuste Version vom November).

Die Installation ist denkbar einfach: Die neuste Version laden (momentan AdSubtract-11-2007.zip) und die enthaltenen CSS-Datei in einem beliebigen Verzeichnis entpacken (der Einfachheit halber nutze ich dazu Safari/Plugins).

In Safari in Bearbeiten > Einstellungen > Erweitert >Stylesheet die entpackte AdSubstract.css auswählen.

Fertig. Jetzt wird schon einmal ein großer Teil der Werbung blockiert.

Das Servicepack findest sich jetzt seit gut einem Tag auf meinem Notebook. Die Erfahrungen direkt nach der Installation: Es dauert alles wieder länger, in etwa so lange, wie es brauchte als Vista neu war. Das Starten von Vista, Herunterfahren, Standby, Starten von Anwendungen: Nichts davon ist schneller geworden, im Gegenteil. Einen (guten) Grund dafür gibt es aber: Das Einspielen des SP1 löscht die Profildaten, die SuperFetch anlegt um die Daten effizient (vor)zuladen.

Meine Erfahrung bisher bestätigt dies: Nach einem Tag und einigen Neustarts geht es wieder aufwärts, die Daten werden wieder neu gesammelt. Laut Microsoft kann dieser Vorgang einige Tage bis Wochen andauern bevor die volle Geschwindigkeit erreicht wird. Meine langsame Notebookfestplatte tut hier ihr übriges.
Aber es gibt auch positive Wirkungen des SP1s: Der Standbybetrieb ist viel schneller geworden. Der Übergang dahin ist wie gewohnt langsam, aber das Reaktivieren von Windows braucht jetzt nur noch zwei Sekunden auf meinem Notebook – für den mobilen Betrieb eine echte Bereicherung.

Das Kopieren von Daten hat sich merklich beschleunigt, einen guten Vergleich und Benchmarks finden sich bei den Kollengen vom Vistablog unter vistablog.at.

Weitere Verbesserung: Die Startmenusuche fühlt sich etwas schneller an. Auch Vorschaubilder von Bilddateien werden im Explorer spürbar schneller geladen.

Ein neues Problem blieb bestehen. Kurz vor SP1-Installation find meine Audioausgabe an zu knacksen. Dabei handelt es sich um ein bekanntes Vistaproblem, welches mich bisher aber nicht betraf. Entweder sind daran die Realtek-Treiber schuld, oder aber mein neuer Bluetooth-Stick (Hama Nano mit Toshiba-Stack).

Momentan ist mein Rechner zudem ein rechter Hitzkopf, die CPU ist oft sehr warm (ca. 60°C, sonst um 50 °C). In wie weit das aber mit dem SP1 zusammen hängen soll kann ich nicht sagen – an der Akkuausdauer hat sich jedenfalls nichts geändert. Ursache wird hier wahrscheinlich der neue Catalyst 8.2 (für Grafik und Chipsatz) sein, der vor dem SP1 eingespielt worden ist. Ursache scheint hier der Verlust der Eintellungen vom RightMark CPU Clock Utility zu sein. Habe diese jetzt wieder hergestellt, und siehe da, die Temperatur sinkt wieder auf alte Werte!

Unterm Strich hat sich auf den ersten Blick also nicht viel verändert, ein paar Verbesserungen gibt es hier und da. Wer vor dem SP1 keine Probleme mit seinem Windows Vista wird jetzt aber wohl auch keine großen Änderungen spüren.

Update:

– Der Grund für die Erwärmung wurde oben schon korrigiert.

– Das Problem mit dem Aussetzern bei der Audiowiedergabe habe ich auch in den Griff bekommen. Schuld ist offensichtlich die Aktivität des Bluetoothstacks. Ist dieser beendet (einfach die Bluetooth-Anwendung in der Taskleiste beenden), läuft alles wie es soll. Nach einem neuen Start des Bluetooth Mangagers kommen die Aussetzer bisher auch nicht wieder.

Jetzt bin ich doch so weit. Weil ich so unendlich viel vom SP1 lesen muss probiere ich das jetzt einmal am eigenem Leib aus. Besonderns gewagt dabei: Meine Ati-Chipsatz im Notebook kombiniert mit HD-Audio und Ethernet von Realtek – beide Hersteller sollen Treiberprobleme in Verbindung mit Windows Vista SP1 haben. Auch interessant zu sehen wird sein, ob mein Bluetooth Dongle (Hama Nano) das Update verträgt.

Zur Sicherheit lege ich jedoch noch einen manuellen Wiederherstellungspunkt an – man kann ja nie wissen. Damit mir keine gestorbenen Prozesse oder sonstige Unannehmlichkeiten den Spaß verderben starte ich noch einmal schnell neu. Alle Anwendungen die nebenbei laufen, wie Pidgin, werden beendet. Und schon kann es losgehen!

17:18 Starten des Updates. Hinweis auf Wissenwertes, Lizenzbedingungen, Installieren! Sehr höflich: Der Installer bietet mir an selbst die Neustarts durchzuführen, die nötig sein werden. Aber gerne! Noch ein Hinweis: „Die Installation kann länger als eine Stunde dauern“. Laaangweilig! Jetzt heißt es wohl abwarten und Kaffee trinken.

17:23 Interessant! Der Statusbalken wird immer schneller!
17:23 Jetzt bewegt er sich nicht mehr 😉

17:53 Der Balken hat 100% erreicht. Herunterfahren, „Updates werden konfiguriert“, Neustart beginnt!
17:54 Windows ist gestartet, vor der Anmeldung jedoch stehen geblieben: „Updates werden konfiguriert“

18:23 Der nächste Neustart, gleiches Spiel wie zuvor.

18:26 Schwarzer Bildschirm, aber nen Mauszeiger, Festplattenaktivität. …Jetzt ist der Mauszeiger auch wieder weg. Habe ich da eben einen unbekannten Start-Sound gehört? Hm… „Updates werden konfiguriert“ – wieder 😀

18:42 Bildschirmschoner geht an. Mausbewegung: Loginscreen ist da, ich wähle mich ein. Sieht alles aus wie immer. Kurze Notiz dass ich jetzt Vista SP1 installiert habe. Ich bin fertig! Dauer: 1 Stunde, 24 Minuten.

Vista SP1

Im Geräte-Manager keine Vorkommnisse, Bluetooth geht auch, Bild habe ich und hören kann ich auch was. Trotz aller Hiobsbotschaften wundervolle Langeweile! Die nächsten Stunden werden zeigen, ob es spürbare Änderungen gibt oder nicht.

Da sitzt man Freitag abends in gemütlicher Runde in einer Bar und spricht über Gott und die Welt. Da fängt einer deiner Freunde an zu erzählen, dass seitdem er Windows Vista auf seinem Notebook hat dieses ständig heiß ist und die Lüfter dennoch nicht laufen. Auch Spiele ruckeln nur.

Als Freund des Redmond-Spektakels ist man natürlich schnell dabei die Schuld nicht dem Betriebssystem, sondern dem Anwender zu geben. Die Rechnung geht aber nur auf, wenn man nicht, wie in meinem Fall jedoch geschehen, einen Linux-Aktivisten mit am Tisch hat: „Vista hat ’nen total mieses Energiemanagement!“ „Stimmt ja gar nicht“ „Stimmt ja wohl, steht sogar auf heise„. Trotz kurzer Recherche, Opera Mobile sei Dank, dafür kein Beweis. Kann es auch nicht geben, auf heise.de stand nur, dass es beim SP1 mit ein paar Treibern Probleme gibt, und dass es sein kann, dass Notebooks im Akkubetrieb wesentlich kürzer durchhalten. Meiner Meinung aber ein Hardware-Software-Problem seitens des Herstellers, bei anderen Geräten geht es ja auch. Ich beharre auf meiner Anwendertheorie.

Doch lamentieren hilft meinen Freund nicht weiter, also das Problem angepackt. Das Sorgenkind ist ein zwei Jahre altes Toshiba Satellite Pro P100 mit nVidia GeForce Go7600. Auf der Herstellerseite findet man eine umfangreiche Tool- und Treibersammlung, von denen nicht ein Programm auf dem Notebook war. Kein Wunder, dass dann wohl was mit dem Energiemanagement nicht stimmen kann.

Also erster Schritt: Das BIOS updaten auf einen moderat aktuellen Stand. Und siehe da: Nach dem Update entdeckt Vista neue Hardware und installiert fleißig Treiber. Dabei helfen wir und packen aktuelle Chipsatz-Treiber mit drauf. Probleme gibt es bei der Grafikkarte – von nVidia gibt es dafür keine Vistatreiber (mehr). Zum Glück bietet Toshiba auf der Supportseite ein jahr alte Treiber an, das Neuste, was sich finden ließ. Auch installiert. Dazu kamen alle Tools die sich nach „Energie“ oder „Hardware“ anhörten. Drauf damit!

Total vernachlässigt: Windows Updates. Also die letzten 60 Patches nachinstalliert. Nach unzähligen Neustarts das große Oho-„Wow“-Erlebnis: Das Notebook ist kalt, Spiele laufen mit satten Framerates (so satt wie der Grafikchip sie jedenfalls liefern kann).

Bei Problemen mit Vista in Kombination mit etwas ältere Hadware also immer wie folgt vorgehen:

– BIOS auf Aktualität prüfen und gegebenenfalls erneuern
– Windows auf aktuellem Stand halten mittels Windows Update (und das bitte automatisch!)
– Treiber Treiber Treiber! Sind die nicht aktuell, kann es nicht klappen!
– Bei Notebooks Software zum Steuern des Energiemanagements installieren (gibt es da keine Tools wie RightMark CPU Clock Utility oder Notebook Hardware Control verwenden!)

Sollte Vista dann immer noch nicht wie gedacht laufen, überprüfen ob das Notebook vom Herstellers aus Vista unterstützt. Bei älteren Modellen kann es dann oft heißen: Modell wechseln oder bei XP / Linux bleiben!

Wenn man einmal im Netz danach sucht, wird man rasch fündig. Der Media Player 11 ist zwar einen gute Software geworden, hat aber einen sehr nervigen Fehler (oder ist es ein Feature?) – Will man den WMP beenden, werden Musik oder Videos im Hintergrund weitergespielt. Passiert das unerwünscht muss man entweder den Prozess „wmplayer.exe“ im Taskmanager beenden, oder den WMP neu starten, die Wiedergabe stoppen und den Player wieder beenden.

Beides ist sinnfrei und nervig.

Das Problem ist folgendens: Wird der Player „beendet“ läuft er weiter – und das ist Absicht – kann man doch über die Media Player Symbolleiste in der Taskleiste die immernoch vorhande Wiedergabe steuern. Wie, keine Symbolleiste vorhanden und dennoch Musik? Hier liegt das Problem: Auch wenn die Symbolleiste nicht angezeigt wird, macht der Media Player davon gebrauch – ohne dass man es merkt oder ändern kann.

Also muss man in den etwas säuerlichen Apfel beißen und die Symbolleiste einschalten: Über einen Rechtsklick auf die Taskleiste dessen Kontextmenü öffnen, auf den Eintrag „Symbolleisten“ gehen und in der folgenden Liste „Windows Media Player“ klicken. In der Taskleiste erscheinen jetzt die Media Player Controls sobald dieser minimiert wird (ist der Player sichtbar oder im Hintergrund werden die Controls nicht gezeigt). Daran kann man sich gewöhnen. Und endlich: Jetzt wird auch die Audio- oder Videowiedergabe beendet, wenn der Player geschloßen wird – die Leiste verschwindet in diesem Fall ebenfalls.

Für einige Benutzer ist diese Workaround sicherlich angenehmer als wieder zu iTunes zurück zu kehren 😉